Performance issues processing builds and reporting via website
Incident Report for CodeShip
Resolved
This incident has been resolved.
Posted Mar 01, 2021 - 13:14 UTC
Monitoring
A fix has been implemented and we are monitoring the system.

If you noticed the build status page said "Trigger your first build" - then this was (incorrectly shown) because the build scheduling APIs were timing out.
Posted Mar 01, 2021 - 12:35 UTC
Identified
We are investigating a build scheduling performance issue.

There will be a short interruption to build process while we complete a system upgrade to alleviate stress on the system.
Posted Mar 01, 2021 - 10:08 UTC
This incident affected: CodeShip Basic (Builds) and CodeShip Pro (Builds).