Some build pipelines hanging on Basic
Incident Report for CodeShip
Postmortem

After an investigation of yesterday's incident, it was determined that some monitoring code impacted error handling of our Basic build platform. We have addressed the underlying bug and have identified some additional steps we will take during ongoing incidents to reduce response time.

Posted about 1 month ago. Jan 17, 2019 - 22:26 UTC

Resolved
All build pipelines seem to process as intended and are no longer hanging.
Posted about 1 month ago. Jan 17, 2019 - 10:16 UTC
Monitoring
Issue was identified and a rollback was done. We are now monitoring for any further hanging pipelines.
Posted about 1 month ago. Jan 17, 2019 - 08:00 UTC
Investigating
Build pipelines on Basic are hanging for some projects and we are investigating.
Posted about 1 month ago. Jan 17, 2019 - 07:15 UTC
This incident affected: CodeShip Basic (Builds).