Investigating a problem scheduling builds in our Pro product
Incident Report for CodeShip
Postmortem

An upstream networking incident in AWS's us-east-1 region impacted network communication on our elastic Pro build fleet, leading to build timeouts and failures. In addition to adding more heterogeneity to our fleet of build machines, this outage did help us see areas where communication on the network could be optimized. We apologize for the inconvenience this caused to our customers, and all builds that were impacted should run normally with a restart.

Posted 6 months ago. May 16, 2018 - 15:58 UTC

Resolved
This incident has been resolved.
Posted 6 months ago. May 15, 2018 - 16:34 UTC
Monitoring
AWS is reporting their incident as resolved. Affected Pro builds can now be restarted. Continuing to monitor systems.
Posted 6 months ago. May 15, 2018 - 16:04 UTC
Identified
We are awaiting final resolution from AWS regarding their recent outage -- https://status.aws.amazon.com/
Posted 6 months ago. May 15, 2018 - 15:29 UTC
Update
Starting to see improvements to Codeship Pro build provisioning as we continue to investigate upstream network dependencies.
Posted 6 months ago. May 15, 2018 - 14:42 UTC
Update
We are continuing to investigate this issue.
Posted 6 months ago. May 15, 2018 - 13:57 UTC
Update
We are seeing network issues on Codeship Pro. This can result in builds failing in various stages. Our engineering team is looking into this right now and will update you as soon as we have additional information available.
Posted 6 months ago. May 15, 2018 - 13:55 UTC
Investigating
We are looking into a problem scheduling builds for Codeship Pro. We'll update this page with new information as soon as we get it.
Posted 6 months ago. May 15, 2018 - 13:37 UTC
This incident affected: CodeShip Pro (Builds).