Missing Customer Accounts
Incident Report for CodeShip
Resolved
This incident has been resolved. Please reach out to support with any additional questions.
Posted 3 months ago. Mar 19, 2019 - 19:58 UTC
Monitoring
On 18th March 2019 our engineering team performed maintenance on one of our databases and accidentally soft deleted a small subset of customer accounts. This caused some customer and project information to appear missing or outdated. This was brought to our attention by some customers and we were able to restore the data to its original state. We sincerely apologize for any impact this has had on your day. Please reach out to support if you do not feel the situation has been rectified. Though we have fixed the root cause we are actively monitoring to ensure nothing else was affected. We will be reviewing our processes around data cleanup in order to avoid this from happening again. As well as reviewing our ability to identify issues like this sooner.
Posted 3 months ago. Mar 19, 2019 - 16:28 UTC
This incident affected: CodeShip (Application & API Servers).