GitLab Build Issues
Incident Report for Codeship
Postmortem

While hard at work updating processing for webhooks for other SCM providers, we inadvertently introduced a regression that impacted processing of some builds with code hosted on GitLab. Our automated testing did not alert us to this defect. We have reassessed our testing strategy and are considering other integration testing strategies to prevent further disruptions. We apologize for the inconvenience.

Posted 8 days ago. Jul 10, 2018 - 16:11 UTC

Resolved
This incident has been resolved.
Posted 9 days ago. Jul 09, 2018 - 16:00 UTC
Monitoring
Builds from GitLab should be triggering again and we are continuing to monitor.
Posted 9 days ago. Jul 09, 2018 - 14:47 UTC
Investigating
We are investigating issues with Gitlab-based projects seeing builds not triggering successfully.
Posted 9 days ago. Jul 09, 2018 - 13:05 UTC
This incident affected: SCM Providers (GitLab).