Build dashboards not loading
Incident Report for Codeship
Postmortem

On February 26th, some customers experienced missing build entries on project and build overview dashboards, and may have also experienced sluggishness on those same pages. This was the result of a missing database index.

Once our engineering and CS teams identified the problem, we added the necessary index, and worked on a forward fix for the project and build overview pages. Our team feels that we could have come to a solution earlier and limited the impact. We’ve made a plan to review some internal policies around code review and incident response as a result of this incident. We apologize for the inconvenience.

Posted 7 months ago. Feb 28, 2018 - 17:12 UTC

Resolved
This incident has been resolved.
Posted 7 months ago. Feb 26, 2018 - 23:36 UTC
Investigating
We are investigating issues with the build dashboard not loading
Posted 7 months ago. Feb 26, 2018 - 22:57 UTC