AWS CLI Issues on Codeship Basic
Incident Report for Codeship
Resolved
This incident has been resolved.
Posted 7 months ago. Feb 15, 2018 - 22:23 UTC
Monitoring
Deployed a change to lock the AWS CLI version at 1.14.38 for now. If you are using an integrated AWS deploy with Codeship, it should work again now.

If you are installing the CLI manually with pip in your build and are still seeing the error you can also lock the version by installing with pip install awscli==1.14.38.
Posted 7 months ago. Feb 15, 2018 - 20:57 UTC
Identified
We are again seeing issues with AWS CLI on Codeship Basic due to upstream problems with the AWS CLI package.

See here for more info: https://github.com/aws/aws-cli/issues/3149

For the time being, clearing your cache and restarting your builds will work intermittently. We are investigating other solutions.
Posted 7 months ago. Feb 15, 2018 - 18:36 UTC